Oracle Java 8 telepítése Ubuntura

14.04-re, 12.04-re

A javás alkalmazások többsége vígan elfut az Ubuntu szoftverközpontból telepíthető OpenJDK 7-tel, de vannak olyan programok, mint pl. az AbevJava, amelyek csak a Java 8-cal hajlandóak működni.

Itt most azt fogom leírni, hogy hogy lehet a Java 8-nak az Oracle által kiadott változatát a többi Ubuntu-csomaghoz hasonlóan tárolóból telepíteni. Ennek az az előnye, hogy így a Java 8 frissen tartását is rábízhatjuk a Frissítéskezelőre, nem kell vele külön foglalkoznunk.

Az Oracle Java 8-hoz nincs telepítőcsomag az Ubuntu hivatalos tárolóiban, ezért előbb hozzá kell adnunk a tárolóját.

  1. Indítsuk el a Terminált:

    Terminál indítása

  2. Másoljuk be a Terminálba az alábbi parancsot, majd nyomjuk le az Entert:

    sudo add-apt-repository ppa:webupd8team/java

    A sudo kérni fogja a jelszavunkat. Gépeljük be (nem fog látszani), majd nyomjuk le az Entert. Fussunk végig a személyes csomagtároló bemutatkozásán, majd Enterrel hagyjuk jóvá a tároló hozzáadását.

  3. Frissítsük a telepíthető csomagok listáját:

    sudo apt-get update
  4. Most már kiadhatjuk az utasítást az Oracle Java 8 telepítésére:

    sudo apt-get install oracle-java8-installer
  5. A Terminálban elő fog ugrani egy párbeszédablak, amely arról fog tájékoztatni, hogy a Java telepítéséhez el kell fogadnunk a licencszerződést. Nyomjuk le az Entert, hogy megértettük.

  6. A második ilyen párbeszédablakban már „Igen”-nel vagy „Nem”-mel kell válaszolnunk arra, hogy elfogadjuk-e a licencszerződést. A tabulátorral vagy a balra mutató nyíllal ugorjunk át a <Nem>-ről az <Igen>-re, majd nyomjuk le az Entert.

    Oracle Binary Code License Agreement

    Ezután már csak meg kell várnunk, hogy végigfusson a telepítés.

2 thoughts on “Oracle Java 8 telepítése Ubuntura

  1. Sziasztok!

    Arra a problémára futottam rá, hogy mindenképpen a java8-at kellene telepítenem.
    Azonban a rendszer már csak a 11-et hajlandó felpakolni.
    Tudnátok-e esetleg segíteni, hogy hogyan tudnám mégis felrakni a 8-as verziót?

    Előre is köszönöm a segítséget.

    A 2. pontban leírtak után azt mondja a rendszer, hogy:
    The Oracle JDK License has changed for releases starting April 16, 2019.
    The new Oracle Technology Network License Agreement for Oracle Java SE is substantially different from prior Oracle JDK licenses. The new license permits certain uses, such as personal use and development use, at no cost — but other uses authorized under prior Oracle JDK licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available here: https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html

    Oracle Java downloads now require logging in to an Oracle account to download Java updates, like the latest Oracle Java 8u211 / Java SE 8u212. Because of this I cannot update the PPA with the latest Java (and the old links were broken by Oracle).

    For this reason, THIS PPA IS DISCONTINUED (unless I find some way around this limitation).

    Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK8). There are no actual Java files in this PPA.

    Important -> Why Oracle Java 7 And 6 Installers No Longer Work: http://www.webupd8.org/2017/06/why-oracle-java-7-and-6-installers-no.html

    Update: Oracle Java 9 has reached end of life: http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

    The PPA supports Ubuntu 18.10, 18.04, 16.04, 14.04 and 12.04.

    More info (and Ubuntu installation instructions):
    http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html

    Debian installation instructions:
    – Oracle Java 8: http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html

    For Oracle Java 11, see a different PPA -> https://www.linuxuprising.com/2018/10/how-to-install-oracle-java-11-in-ubuntu.html
    More info: https://launchpad.net/~webupd8team/+archive/ubuntu/java
    Press [ENTER] to continue or Ctrl-c to cancel adding it.

    Illetve a 4-es pont után:

    Csomaglisták olvasása… Kész
    Függőségi fa építése
    Állapotinformációk olvasása… Kész
    oracle-java8-installer csomag nem elérhető, de egy másik hivatkozik rá.
    A kért csomag hiányzik, elavult vagy csak más forrásból érhető el

    E: „oracle-java8-installer” csomagnak nincs telepítésre jelölt verziója

Vélemény, hozzászólás?

Adatok megadása vagy bejelentkezés valamelyik ikonnal:

WordPress.com Logo

Hozzászólhat a WordPress.com felhasználói fiók használatával. Kilépés /  Módosítás )

Google kép

Hozzászólhat a Google felhasználói fiók használatával. Kilépés /  Módosítás )

Twitter kép

Hozzászólhat a Twitter felhasználói fiók használatával. Kilépés /  Módosítás )

Facebook kép

Hozzászólhat a Facebook felhasználói fiók használatával. Kilépés /  Módosítás )

Kapcsolódás: %s